Very poor battery life

Rebel 3.0
20
10

Very poor battery life

I don't know what could be causing this, but the upper right of my phone is almost always hot to the touch.

Any ideas?
5 REPLIES
Rebel on the Rise Rebel on the Rise
821
459

Re: Very poor battery life

@CQd44 I remember installing T-mobile sucked up a LOT of my battery life. Try uninstalling it, and see how your battery life fares then...

Join the force! ->https://programs.nextbit.com/

Dancing cat approves!
Rebel 3.0
61
38

Re: Very poor battery life

[ Edited ]

Chacko1 wrote:

@CQd44 I remember installing T-mobile sucked up a LOT of my battery life. Try uninstalling it, and see how your battery life fares then...


I have to agree with you. That app is a true battery suck.  

I forgot where I read it, but I have seen others say that they have experienced the same thing with the app. Either limit its permissions or uninstall it. I recommend the latter.

Rebel 3.2
94
67

Re: Very poor battery life

I also had to uninstall Tmobile, it is a resource hog.  I was lucky to midway through the day with that installed, without it my battery life improved greatly.  To the OP, go into your settings > battery and post a screenshot so we can see what is using the most battery.  

Rebel 3.0
24
12

Re: Very poor battery life

[ Edited ]

CQd44 wrote:
I don't know what could be causing this, but the upper right of my phone is almost always hot to the touch.

Any ideas?

You wouldn't happen to run Skype do you? That seems to eat the hell out of my battery.

 

charging.jpg

Another app that will put you in this spot 2 hours from the end of the workday is.....

 

 

 



.... HEARTHSTONE

I have 2 of these chargers. One at home and one at work. I have 5 charge cables. 1 at home, 1 at work, 1 in my card, 1 in work car, and 1 on reserve. Smiley Happy

Rebel 2.6
4
0

Re: Very poor battery life

For some reason it's not letting me make a post so here goes, I recently factory reset my phone and installed nova launcher. And now I know that the robins battery life isn't that great but I have some wierd stats, the battery graph declines almost instantly to 0 but the battery usage breakup underneath shows only 47%, pics attached.