Connecting phone to a mac

SOLVED
Rebel 3.0
24
7

Re: Connecting phone to a mac

[ Edited ]

That would help. Thanks. @Baymax

Nextbit Product Expert Nextbit Product Expert
898
582

Re: Connecting phone to a mac

Crap! I totally forgot to get on teamviewer last night @yDaniel98

 

My apologies. Working long hours gets to me sometimes.

I do not work for Nextbit; I am an expert on the product though. PM if needed.

Contact me through PM if I am needed.

Rebel 3.0
24
7

Re: Connecting phone to a mac

[ Edited ]

Dont worry. After all, you are the one helping me out. Just tell me when you are available and I will PM you my Team Viewer info. Smiley Happy

 

@Baymax

Rebel 3.0
24
7

Re: Connecting phone to a mac

@Baymax

 

Thanks for offering your help. I really appreciated. I found out that the problem was with my computer. Smiley Happy Smiley Happy Smiley Happy

Rebel 3.0
24
7

Re: Connecting phone to a mac

I almost forgot to post the solution. I should note that I have no idea why it worked, but it did.

 

I made a partition in my computer's memory. Then I installed a separate version of OSX. When I booted to that partition the Robin connected flawlessly. I thought that it would only work in the partition I created, however, when I booted back to the default partition, the Robin connected.

 

For perspective, here is a list of the things I tried before I got it to work:

 

- Fast booting the Robin.

- Rebooting the Robin.

- Wiping the cache of the Robin.

- Restarting my computer.

- Clearing the SMC and NVRAM of the computer.

- Turning on usb debugging.

- Switching between usb modes in developer options.

- Probing the usb ports in my computer (software).

- Disconnecting and connecting the usb several times out of pure frustration.

- Connecting the Robin to another computer (it connected).

- Uninstalling Android file transfer and reinstalling it.

 

Hopefully one of these things will work if someone has this problem in the future.

 

@Khang

@Baymax

Rebel 3.0
44
36

Re: Connecting phone to a mac

@yDaniel98 - I've aggregated parts of what @Baymax has said in this thread and had a little play around, and it seems that Robin always defaults to Charging Only in the usb cable options.

 

So each time I want the phone to connect to Android File Transfer:

 

- I connect the cable to the phone and computer,

- enable usb debugging

- re-select MTP (as it's most likely changed to Charging Only) from the USB Configuration (on the notifactions if you've enabled USB Debugging).

[you can keep USB debugging on in future to save a step if you're ok with that]

 

That seems to be the most consistent workaround for me until @Khang and the team figure out if this is consistently happening with people's Robins (at least with Macs?)

 

 

Rebel 1.0
1
0

Re: Connecting phone to a mac

I know I'm late to the game, but none of the solutions here worked for me.

Thought I would share my solution after I finally got it working, for anyone stumbling across this thread in the future.

The main issue here is NOT the phone, at least in my case: it's the USB cable. When using the cable that came with the phone, computers recognize the Robin intermittently at best (Tried this on 3 different Macs and 3 Windows PCs). 

 

Solution: Clean the USB contacts (male end) by rubbing them with your shirt / cloth. There's a film over them from the factory that prevents a quality connection.

 

I know this sounds stupid, but try it. It instantly worked for me after hours of headache. I stumbled across this from a different thread - it also fixes charging issues. I have to do this almost every time I use the cord.

 

Environment: I have USB debugging disabled, phone is in file transfer (MTP) mode, using Android File Transfer.