Problem with booting up

SOLVED
Highlighted
ew
Rebel 2.8
7
0

Problem with booting up

Hello everyone, I was using my Robin (with official LineageOS 14.1) yesterday normally. However, in the afternoon, when I tried to unlock the screen, I found that Robin has totally no response. I plugged it into my PC and only a "QHSUSB_BULK" device detected. This means my Robin is bricked (and unable to enter fastboot mode) and it needs to fix via Qualcomm 9008 mode but I'm not sure what to do. Can anyone please help me? Thanks.

6 REPLIES
Ps
Rebel 3.0
71
12

Re: Problem with booting up

Hi ew,

 

Tinkering started a little early Smiley Wink

Let's try and see if we are able do some troubleshooting:

  • Could you post a pic of the error recieved?
  • Was developer options and debugging on (adb etc.) on your robin?
  • I am assuming you would be using TWRP recovery, please confirm.
  • Holding power+lower button for 2-3 minutes while plugged in having any effect?

LineageOS does make the screen sleep for a little while longer if phone is not accessed for sometime, let's hope this is the case with ya.

 

Please report with the above observations and try and see what sticks.

ew
Rebel 2.8
7
0

Re: Problem with booting up

Hi Ps,

 

Thank you for your reply.

 

I don't have a picture or video because there was just no any response. I turned on USB debugging and OEM unlocking and unlocked bootloader before installing LineageOS, then turned them off and locked bootloader after installation. Yes, I am using TWRP recovery (version 3.0.3).

And here comes to the last of your points - after pressing volume down + power button for about 2 minutes while plugging into my PC, it vibrated and showed the boot menu again. I entered the recovery (this time was much slower than before) and the system without having any further problem. That's really amazing!

 

Thank you so much for your help!

Ps
Rebel 3.0
71
12

Re: Problem with booting up

I'm glad I could help, further suggestion would be to keep bootloader and debugging on. Make a nandroid backup for future use.

Please see: hotspot toggle in drop down on lineage OS causes a soft reboot. I have noticed random reboot might occur however they become auto stable in a day or 2 use.

Finally, new build for lineage is out, do upgrade it(you'll have to root again)

You may mark the thread as answered may help others in searching for same issue.

ew
Rebel 2.8
7
0

Re: Problem with booting up

[ Edited ]

I decided to keep the bootloader locked because I need to use Android Pay, I'm not sure if Android Pay will work with bootloader unlocked. Now I can use Android Pay and TWRP simultaneously without any patch. I will switch on USB debugging when necessary.

I've immediately updated to the newest nightly build after successfully booting up my Robin today (TWRP can execute programs and install things with locked bootloader without any issue). Thanks again for your help.

Ps
Rebel 3.0
71
12

Re: Problem with booting up

That's nice. I thought magisk could bypass safety net(?) Maybe I'm wrong, I used magisk and rooted but don't use android pay so never tinkered that way.

Good to know. Keep us updated on the forums maybe participate in section #robincam

 

ew
Rebel 2.8
7
0

Re: Problem with booting up

I know magisk can bypass safety net but I don't want to use any patching method if there is any alternative. For me, Android Pay is quite useful sometimes so I don't want to lose that.

Anyway, thank you again for your help and I will participate in the events if I have free time.