Unbrick Tool for Mac and Windows

Nextbit Employee Nextbit Employee
1311
1604

Re: Unbrick Tool for Mac and Windows

OP has been updated with the 1350 flash script.


#NextNow
Rebel 3.0
74
34

Re: Unbrick Tool for Mac and Windows

Factory reset phone to be safe, used tool, wiped data and now I'm back to stock! Thanks Khang!

Rebel 2.6
3
0

Re: Unbrick Tool for Mac and Windows

hi,

i dont remeber i unlocked my phone. please help me what to do

 

siva kumar

 

Rebel 3.0
74
34

Re: Unbrick Tool for Mac and Windows

When you boot up the phone do you see a menu pop up saying something along the lines of "your bootloader has been unlocked and Nextbit can't check for tampering of device!" If so then the bootloader is unlocked. If not, and you can get to fast boot mode, just run the command 'fasboot -i 0x2c3f oem unlock'

Warning that this WILL wipe your device. Once unlocked, go back into bootloader and run flash-all!
Rebel 2.6
3
0

Re: Unbrick Tool for Mac and Windows

...
oem unlock FAILED (remote: oem unlock is not allowed)
finished. total time: 0.001s

Rebel 2.6
3
0

Re: Unbrick Tool for Mac and Windows

When I run the tool, it gets stuck on:

 

simu_flash:971f0dec:system
sending segment 1 of 'system' (2475972 KB)...

 

I'm guessing that means I need to RMA my device?

Nextbit Employee Nextbit Employee
1311
1604

Re: Unbrick Tool for Mac and Windows

Nope. That means you need to wait as let it run. Sometimes it takes a while. Or just try to reflash.

#NextNow
Rebel 2.6
3
0

Re: Unbrick Tool for Mac and Windows

I've had it running for about an hour and it's still stuck on that line. I've already sent a request for an RMA.

Nextbit Employee Nextbit Employee
1311
1604

Re: Unbrick Tool for Mac and Windows

Ahhh I see. This could be an issue with the data transfer, or cable. Cool you got an RMA going. How did you get into the boot loop or issue/problem?

#NextNow
Rebel 2.6
3
0

Re: Unbrick Tool for Mac and Windows

I tried a different cable with the same results.

 

It happened after I took the most recent OTA. As soon as it rebooted, it started looping. Wiping the phone from recovery didn't fix it. Attempting to run the factory image and the unbrick tool both result in the process locking up on that sending system line.